The MASM Forum Archive 2004 to 2012
Welcome, Guest. Please login or register.
December 12, 2018, 01:48:55 AM

Login with username, password and session length
Search:     Advanced search
128553 Posts in 15254 Topics by 684 Members
Latest Member: mottt
* Home Help Search Login Register
+  The MASM Forum Archive 2004 to 2012
|-+  Project Support Forums
| |-+  IDE Development and Support
| | |-+  [Masmed]Windows XP/Vista Form Design
« previous next »
Pages: [1] Print
Author Topic: [Masmed]Windows XP/Vista Form Design  (Read 4811 times)
morph
Guest


Email
[Masmed]Windows XP/Vista Form Design
« on: October 14, 2009, 11:05:43 PM »

Hello,
i have just installed masmed and created a form ect. Now i was wondering, whether i could make the Style of the form like Windows Xp or Vista. I have included the xp style manifest, just like in c++, but the buttons still look kinda weird. By the way, i have windows 7 running.
If anyone knows a solution, i would be greatful.

/morph
Logged
KetilO
Member
*****
Posts: 980



Re: [Masmed]Windows XP/Vista Form Design
« Reply #1 on: October 16, 2009, 09:51:06 AM »

Hi morph

I have no idea about Windows 7
You probably need to change the xml content.

KetilO
Logged
morph
Guest


Email
Re: [Masmed]Windows XP/Vista Form Design
« Reply #2 on: October 16, 2009, 11:03:31 PM »

Well, is there anything else to do besides creating a new resource file and adding the xp manifest to it?
Logged
BogdanOntanu
Global Moderator
Member
*****
Gender: Male
Posts: 1154


Re: [Masmed]Windows XP/Vista Form Design
« Reply #3 on: October 17, 2009, 09:29:43 AM »

You can also keep the manifest file outside of the application and name it my_app_name.exe.manifest.

Depending on your application you might have to call InitCommonControls as noted here: http://support.microsoft.com/?id=309366

Other than that it should work.
Logged

Ambition is a lame excuse for the ones not brave enough to be lazy.
http://www.oby.ro
morph
Guest


Email
Re: [Masmed]Windows XP/Vista Form Design
« Reply #4 on: October 17, 2009, 02:36:21 PM »

Finally it worked, big thanks to you guys. I think it was the missing InitCommonControls. Thanks.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP The MASM Forum Archive 2004 to 2012 | Powered by SMF 1.0.12.
© 2001-2005, Lewis Media. All Rights Reserved.
Valid XHTML 1.0! Valid CSS!